Introduction

- Please be sure to read and understand Precautions and Introductions in CX-Programmer Operation Manual (W446-E1) before using the product.

- This Guide describes the basic operation procedure of CX-Programmer. Refer to the Help or the Operation Manual of the PDF file for detailed descriptions.

- To read the PDF files, you need Adobe Reader, a free application distributed by Adobe Systems.

- You can display the PDF files from the [Start] menu on your desktop after installing the CX-Programmer.

- The screen views used in this guide may be different from the actual view, and be subject to change without notice.

- The product names, service names, function names, and logos described in this guide are trademarks or registered trademarks of their respective companies.

- The symbols (R) and TM are not marked with trademarks and registered trademarks in this guide respectively.

- The product names of the other companies may be abbreviated in this guide.

- Microsoft product screen shots reprinted with permission from Microsoft Corporation.
Contents

Available PC
Available Device Types

Chapter 1 Installation - Startup

1. Installation ......................................................... 1-1
   1-1. Installation of CX-Programmer ......................... 1-1
   1-2. Online Registration ........................................ 1-1
2. Startup of CX-Programmer ..................................... 1-2
3. New Project Opening and Device Type Settings ............ 1-3
4. Main Window ...................................................... 1-4
   4-1. Compatible SYSWIN Key Allocation ..................... 1-5
   4-2. Section ........................................................ 1-6
   4-3. Deletion and Display of Unnecessary Windows ......... 1-8
5. Program Creation ................................................ 1-9
   5-1. Entry of Normally Open Contact ....................... 1-10
   5-2. Entry of Coil ............................................... 1-11
   5-3. Edit of Symbol Comment ................................ 1-13
   5-4. Entry of Rung Comment .................................. 1-14
   5-5. Entry of Normally Closed Contact .................... 1-14
   5-6. Entry of Attached Comments ............................ 1-15
   5-7. Entry of Differential Contact…Up ..................... 1-16
   5-8. Entry of Differential Contact…Down .................. 1-16
   5-9. Entry of Vertical…Up ...................................... 1-17
   5-10. Entry of Vertical…Down ................................ 1-17
   5-11. Entry of Advanced Instructions 1 - Entry of Strings 1-18
   5-12. Entry of Advanced Instructions 1 - Useful Functions 1-19
   5-13. Entry of Auxiliary Relay - 1.0 Second Clock Pulse Bit 1-20
   5-14. Entry of Advanced Instructions 2 - Entry of Differential 1-21
   5-15. Entry of OR Rung ......................................... 1-22
   5-16. Entry of Advanced Instructions 3 - Entry by Fun No. 1-23
   5-17. Entry of Timer Instructions ............................ 1-24
   5-18. Entry of Counter Instructions .......................... 1-25
   5-19. Edit of Rungs…Copy & Paste ............................ 1-26
   5-20. Entry of END Instruction ................................. 1-26

Chapter 2 Online Operation

1. Program Error Check (Compile) .............................. 2-1
2. Going Online ..................................................... 2-2
3. Monitoring ....................................................... 2-3
   4. Monitoring - 2 Monitoring Many Locations in Program at Once 2-4
   5. Monitoring - 3 Monitoring in Hex .......................... 2-4
   6. Monitoring - 4 Watch Window ............................. 2-5
   7. Monitoring - 5 Present Value Change and Binary Monitoring in Watch Window 2-6
   8. Useful Functions of Watch Window ........................ 2-7
   9. Monitoring - 6 Watch Window - 2 .......................... 2-8
   10. Monitoring - 7 Rung-wrap of Long Rung on Display .......... 2-9
   11. Monitoring - 8 Differential Monitor ........................ 2-10
   12. Force OnOff ................................................... 2-11
   13. Displaying List of Forced-on/off Bits ..................... 2-11
   14. Changing Set Value of Timer .............................. 2-12
   15. Changing Present Value of Timer .......................... 2-12
   16. Find Function - 1 Find from Address Reference Tool .... 2-13
   17. Find Function - 2 Retrace Find of Ladders ............... 2-14
   18. Find Function - 3 Find by Keyword in Comment .......... 2-16
   19. Find Function - 4 Go To Rung Comment ................... 2-17
   20. Find Function - 5 Find Bit Addresses ..................... 2-18
   21. Online Edit ................................................... 2-19

Useful Functions .................................................... Appendix
# Available PC

## Hardware Requirements

<table>
<thead>
<tr>
<th>Item</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system (OS)</td>
<td>Microsoft Windows XP (Service Pack 3 or higher)</td>
</tr>
<tr>
<td></td>
<td>Microsoft Windows Vista (See note 4.)</td>
</tr>
<tr>
<td></td>
<td>Microsoft Windows 7 (See note 4.)</td>
</tr>
<tr>
<td>Computer</td>
<td>Computer with a processor recommended by Microsoft.</td>
</tr>
<tr>
<td>Memory</td>
<td>Memory capacity recommended by Microsoft.</td>
</tr>
<tr>
<td>Hard disk</td>
<td>Approx. 3.4 GB or more available space is required to install the complete CX-One package.</td>
</tr>
<tr>
<td>Display</td>
<td>XGA (1024 x 768), High Color (16 bit) or better</td>
</tr>
<tr>
<td>Disk drive</td>
<td>CD-ROM drive or DVD-ROM drive</td>
</tr>
<tr>
<td>Communications ports</td>
<td>RS-232C port, USB port, or Ethernet port (see note 3.)</td>
</tr>
<tr>
<td>Other</td>
<td>Internet access is required for online user registration, including a modem or other hardware connection method.</td>
</tr>
</tbody>
</table>

**Note (1)** CX-One Operating System Precaution

1) System requirements and hard disk space may vary with the system environment.
2) Except for Windows XP 64-bit version.
3) The amount of memory required varies with the Support Software used in CX-One for the following Support Software. Refer to user documentation for individual Support Software for details.
   - CX-Programmer, CX-Designer, CX-Thermo, CX-Simulator, CX-Protocol, CX-Motion, CX-Drive, CX-Process Tool, and Faceplate Auto-Builder for NS
4) Refer to the hardware manual for your PLC for hardware connection methods and cables to connect the computer and PLC.
   - While the computer and a CJ2/CP-series PLC are connected via a USB cable, the computer cannot go on standby.

**Application Restriction**

**CX-Designer/ NV-Designer**

- If a new Windows Vista font (e.g., Meiryo) is used in a project, the font size on labels may be bigger and protrude from the components if the project is transferred from CX-Designer running on a Windows XP or earlier OS to the NS/NSJ.

**CX-Programmer/ CX-Integrator/ Network Configurator**

- Although you can install CPS files, EDS files, Expansion Modules, and Interface Modules, the virtual store function of Windows Vista or Windows 7 imposes the following restrictions on the use of the software after installation. These restrictions will not exist if application data is installed using Run as Administrator.
  - If another user logs in, the applications data will need to be installed again.
  - The CPS files will not be automatically updated.

**CX-Server**

- Restrictions are imposed on the following functions.
  - The driver cannot be changed from the default setting if Controller Link is set as the network type in the Change PLC dialog box.
  - Online connections will not be possible through Controller Link Boards or SYSMAC LINK Boards.
  - Online connections using FinsGateway as the network type will not be possible from the CX-Programmer or CX-Integrator.
  - Communications will not be possible though a CS1 Board and PCI bus.
### Available Device Types

CX-Programmer supports the following PLC (Programmable Logic Controller) types.

<table>
<thead>
<tr>
<th>Series</th>
<th>CPU Unit Type</th>
</tr>
</thead>
</table>
| **CS** | CS1H-CPU67/66/65/64/63(-V1)  
CS1G-CPU45/44/43/42(-V1)  
CS1G-CPU45H/44H/43H/42H  
CS1H-CPU67H/66H/65H/64H/63H  
CS1D-CPU67H/65H  
CS1D-CPU67S/65S/44S/42S  |
| **CJ** | CJ2H-CPU68/67/66/65/64-EIP/68-EIP  
CJ1G-CPU45/44  
CJ1M-CPU23/22/21/13/12/11  
CJ1G-CPU45H/44H/43H/42H  
CJ1G-CPU45P/44P/43P/42P  
CJ1H-CPU67H/66H/65H  
CJ1H-CPU67H-R/66H-R/64H-R  |
| **C1000H** | C1000H-CPU01(-V1)  |
| **C2000H** | C2000H-CPU01(-V1)(Simplex system only)  |
| **C2000H** | C2000H-CPU01/02/03/11/21/22/23/31  |
| **C2000HX** | C2000HX-CPU34/44/54/64  
C2000H-CPU33/43/53/63  
C2000E-CPU11/32/42  |
| **C2000HE** | C2000HE-CPU34-Z/CPU44-Z/CPU54-Z/CPU64-Z/CPU65-Z/CPU85-Z  
C2000HE-CPU33-Z/CPU43-Z/CPU53-Z/CPU63-Z  
C2000HE-CPU11-Z/CPU32-Z/CPU42-Z  |
| **C2000HS** | C2000HS-CPU01/03/21/23/31/33  |
| **CP (*)** | CP1H-XA40DR-A/XA-40DT-D/XA40DT1-D  
CP1H-X40DR-A/X-40DT-D/X40DT1-D  
CP1H-Y20DT-D  
CP1L-M60D□□□/M40D□□/M30D□□  
CP1L-L20D□□□/L14D□□/L10D□□  
CP1L-EM□□□□□  
CP1L-EL□□□□□  
CP1E-E□□□□□/S□□□□  
CP1E-N□□□□□/S□□□□  |
| **CPM2□ (*)** | CPM2A-20CD/30CD/40CD/60CD  
CPM2C-10CD/10CD/20CD/20CD/32CD  |
| **CPM2□-S□ (*)** | CPM2C-S100C/110C  
CPM2C-S110C-DRT  |
| **CPM1/CPM1A (*)** | CPM1(A)-10CDR/20CDR/30CDR/40CDR (-V1)  
CPM1A-10CDT/20CDT/30CDT/40CDT (-V1)  
CPM1A-10CDT1/20CDT1/30CDT1/40CDT1 (-V1)  |
| **CQM1H** | CQM1H-CPU11/21/51/61  |
| **CQM** | CQM1-CPU11/21/41/42/43/44/45  |
| **CV1000 (*)** | CV1000-CPU01 (-V1)  |
| **CV2000 (*)** | CV2000-CPU01 (-V1)  |
| **CV500 (*)** | CV500-CPU01 (-V1)  |
| **CVM1** | CV1M-CPU01/11 (-V1) (-V2)/ CPU21-V2  |
| **NSJ** | G5D( Common to NSJ5-TQ0□-G5D, NSJ5-SQ0□-G5D, NSJ8-TV0□-G5D, NSJ10-TV0□-G5D, NSJ12-TS0□-G5D )  
M3D( Common to NSJ5-TQ0□- M3D, NSJ5-SQ0□- M3D, NSJ8-TV0□- M3D )  |
<table>
<thead>
<tr>
<th>Series</th>
<th>CPU Unit Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>FQM1 Series Flexible Motion Controller(*5)</td>
<td>FQM1-CM001/MMA21 / MMP21</td>
</tr>
<tr>
<td>IDSC</td>
<td>IDSC-C1DR-A/C1DT-A</td>
</tr>
<tr>
<td>SRM1 (*1)</td>
<td>SRM1-C01/C02 (-V1) (-V2)</td>
</tr>
<tr>
<td>SYSMAC Board, or SYSMAC CS1 Board</td>
<td>C200PC-ISA01 (C200HG-CPU43 *3)</td>
</tr>
<tr>
<td>(Internal connection of a PC with the</td>
<td>C200PC-ISA02-DRM (C200HG-CPU43 *3)</td>
</tr>
<tr>
<td>SYSMAC board that is built-in the PC</td>
<td>C200PC-ISA02-SRM (C200HG-CPU43 *3)</td>
</tr>
<tr>
<td>where CX-Programmer is installed)</td>
<td>C200PC-ISA03 (C200HG-CPU43 *3)</td>
</tr>
<tr>
<td></td>
<td>C200PC-ISA03-DRM (C200HG-CPU43 *3)</td>
</tr>
<tr>
<td></td>
<td>C200PC-ISA03-SRM (C200HG-CPU43 *3)</td>
</tr>
<tr>
<td></td>
<td>C200PC-ISA13-DRM (C200HX-CPU64 *3)</td>
</tr>
<tr>
<td></td>
<td>C200PC-ISA13-SRM (C200HX-CPU64 *3)</td>
</tr>
<tr>
<td></td>
<td>CS1PC-PCI01-DRM (CS1G-CPU45 *4)</td>
</tr>
<tr>
<td></td>
<td>CS1PC-PCI01H-DRM (CS1G-CPU45H *4)</td>
</tr>
</tbody>
</table>

*1: For WS02-CXPC2-V\(\square\) (one license (limited to micro PLCs), only these PLC types are available.
*2: CX-Programmer does not support SFC.
*3: To connect with SYSMAC Board, specify the PLC types in parentheses. Only when selecting these PLC types, you can select “SYSMAC Board” as a network type.
*4: To connect with SYSMAC CS1 Board, specify PLC types in parentheses. Only when selecting these PLC types, you can select “CS1 Board” as a network type.
*5: Insert one FQM1-CM001 and multiple FQM1-MMA21/MMP21 as PLCs into the same project.
Chapter 1
Installation to Startup
1. Installation procedure of CX-Programmer

1-1. Installing CX-Programmer

CX-Programmer is included in CX-One FA Integrated Tool Package. For details on procedures for installing the CX-Programmer from the CX-One, refer to the CX-One Setup Manual (W463-E1) provided with CX-One.

Before installation of CX-One, you must:
• Terminate all Windows programs.
• Uninstall older version of CX-Programmer and peripheral tools (such as CX-Protocol) if they are already installed.

1-2. Online Registration

If you have Internet environment for the installed PC, you can perform online user registration. After installation is completed, [Online Registration] dialog box is displayed.

If you click [Register] button, your Web browser is started to connect to “Omron’s CX-One Web site”.(1)(2)

(1): If you click [Exit] button to cancel online registration, [Online Registration] dialog box is displayed every time CX-Programmer is started.
(2): If you do not have Internet environment, or you do not want to register online, fill and send the user registration card that comes with the product.

MEMO
Use to record license No. etc.
2. Startup of CX-Programmer

The initial screen when starting up CX-Programmer is displayed.
3. New Project Opening and Device Type Settings

Click the toolbar button [New] in CX-Programmer.

Click the left mouse button on the “Settings” button to show the [Device Type Settings] dialog.

Click the left mouse button on and select a CPU type.

Click [OK] to decide the selected CPU type.
4. Main Window

Each function of the main window is explained here.

Title Bar
- Shows the file name of saved data created in CX-Programmer.

Menus
- Enable you to select menu items.

Toolbars
- Enable you to select functions by clicking icons. Select [View] -> [Toolbars], and you can select toolbars to be displayed. Dragging toolbars enables you to change the display positions by the group.

Section
- Enables you to divide one program into a given number of blocks. Each can be created and displayed.

Project Workspace
- Controls programs and data. Enables you to copy data by the element by executing Drag and Drop between different projects or within a project.

Ladder Window
- A screen for creating and editing a ladder program.

Output Window
- Shows error information in compiling (error check).
- Shows the results of searching for contacts/coils in the list form.
- Shows error details when errors occurred while loading a project file.

Status Bar
- Shows information such as a PLC name, online/offline, location of an active cell.

Information Window
- Displays a small window to show the basic shortcut keys used in CX-Programmer. Select [View] -> [Information Window] to show or hide the Information window.

Symbol Bar
- Displays the name, address or value, and comment of the symbol presently selected by the cursor.
4-1. Compatible SYSWIN Key Allocation

The keyboard mapping function allows the function keys to operate like SYSWIN.

Select the [Tools] -> [Keyboard Mapping...] menu.

When SYSWIN key allocation is selected, a key operation guide will be displayed at the bottom of the display.

After the above operations, the key allocations will be changed and become compatible with SYSWIN.

When SYSWIN key allocation is selected, a key operation guide will be displayed at the bottom of the display.

Function keys will be available for entering ladder programs.

Click the icon shown in the task bar on the right-bottom of the display.

Display in Normal View

Display in Full View
4-2. Section

Section is a function to create/display a "block" of a program divided per function. It improves not only the visibility of a program but also the development productivity by reusing components if the program consists of similar controls, because copy and paste on the program tree are available. Moreover, program upload by section is possible and it enables you to do online operation smoothly.

Example

Giving names indicating the contents of processing or controls is possible.

Changing the order of sections and copy & paste are possible by drag & drop with a mouse.

There is no limit on the number of sections per program.

Changing a section name

Click the right button of the mouse on the section whose name is to be changed.

Select [Rename].

Enter a given name.
Addition of a section

Click the right mouse button on [NewProgram1].

Select [Insert Section].

It is possible to go to each section (a ladder block) from a section list.

Perform the same operation as the previous page to name the inserted section.

Double-click a section that you want to check its ladder.

As checking the global image (control flow) of a program on the section list, you can go to a specified section.
4-3. Deletion and Display of Unnecessary Windows

To delete Project Workspace,
Press from a keyboard
\[\text{Alt} + 1\]
Press [Alt]+[1] to show Project Workspace again.

To delete Output Window,
Press from a keyboard
\[\text{Alt} + 2\]
5. Program Creation

Coding of a simple program is explained here.
Select [Tools] -> [Change Input Mode] -> [Classic Mode] from the menu.

After checking the cursor position at the upper left of Ladder Window, start programming.

5-1. Entry of Normally Open Contact

Press [C] from a keyboard to open the [New Contact] dialog.

0 of the upper digit of an address can be omitted.

Enter a symbol comment.

Deletion of instructions
- Move the cursor to the instruction and then press the DEL key.
- Move the cursor to the right cell of the instruction and press the BS key.

0 of the upper digit of an address is omitted when shown.
[] (period) is displayed between a channel number and a relay number.
5-2. Entry of Coil


Press [R] to normalize a rung.

Useful Function: Automatic check of duplicated coils
If a duplicated coil is entered during program creation, the following message is displayed and you can notice that the coil is duplicated right away.

Press the [ESC] key to close the open Output Window.

Double-click by using a mouse (or press F4). The cursor moves to the place of the applicable coil on Ladder Window.

The place of a duplicated coil in the program is displayed.
1. Press [Alt]+[Y]. You can switch showing/hiding of Symbol Comment.

2. Click the toolbar button [Show Program/Section Comments] to switch the display of the comments shown in the head row.

3. Select [Tools] | [Options] from the CX-Programmer menu. You can set hiding of the comment entry dialog.

Click the check box to remove the check mark.

The comment entry dialog is not displayed anymore.
5-3. Edit of Symbol Comment

Ladder Window is switched to the Symbol Comment Editing window.

Double-click the left mouse button on a bit number that you want to enter a symbol comment, and you will able to enter a symbol comment.

Example of copying & pasting comments of two bits

Drag the mouse with the right mouse button pressed to invert the source bits of copy in blue.

Click the right mouse button on the range, and select [Copy] from the popup menu.

Copy&Paste of symbol comments is possible between Excel and CX-Programmer too.

Click the right mouse button on the bit number of the copy destination, and select [Paste].

The comments of the selected two bits are copied.
5-4. Entry of Rung Comment

Move the cursor to this position. (The rung is inverted in blue.)

[Process_at_Startup]
Enter a rung comment.

ENT

The entry screen shows up.

5-5. Entry of Normally Closed Contact

Press "/" from a keyboard to show the [New Closed Contact] dialog.

Sensor 1

ENT
5-6. Entry of Attached Comments

This function is very useful for keeping change histories at maintenance and notes of debug bits at startup.

Move the cursor to the contact to which you want to write an annotation.

Or click the right mouse button.

-> [Properties]

Enter [Mar. 2002 Added by Tanaka, Maintenance Dept.].

Press [Alt] + [A] to switch showing/hiding of attached comments.
5-7. Entry of Differential Contact...Up

Click Detail>>

Click [Up].

Click

This entry method is available only for CS/CJ and CV series PLCs. For the other series PLCs, use DIFU (13).

5-8. Entry of Differential Contact...Down

Click Detail>>

Click [Down].

This entry method is available only for CS/CJ and CV series PLCs. For the other series PLCs, use DIFD (14).
5-9. Entry of Vertical…Up

Ctrl + ↑
Or
U

200
ENT
Coil 2

ENT
R

200
ENT
ENT

300
ENT
Coil 3

ENT

5-10. Entry of Vertical…Down

Ctrl + ↓
Or
V
5-11. Entry of Advanced Instructions 1 - Entry of Strings

Show the [New Instruction] dialog.

Enter an instruction and its operand.

Enter a comment.

See the next page for the contents of instructions.
5-12. Entry of Advanced Instructions 1 - Useful Functions

Instruction Help Function

Find Instruction Function

PLCs supporting the applicable instruction are listed.
5-13. Entry of Auxiliary Relay - 1.0 Second Clock Pulse Bit

Show the [New Contact] dialog.

Click

Select [P_1s] from the pull-down menu.
5-14. Entry of Advanced Instructions 2
- Entry of Differential Instructions

Differential Instructions...instructions executed in only one scan when running a program.

Show the [New Instruction] dialog.

Enter @MOV #0 D100

Attach @ (at mark) before instructions. It makes the instructions differential.

Enter a comment if necessary.

Refer to the former pages to execute coding.
Refer to the former pages to execute coding.

5-15. Entry of OR Rung

Entry of comments is omitted here.

Refer to the section 5-6 to enter annotations.
5-16. Entry of Advanced Instructions 3 - Entry by Fun No.

Show the [New Instruction] dialog.

Enter #0 D0 ✪ ENT ✪

The instruction corresponding to the entered Fun No. is displayed.

021

Refer to the section 5-4 to enter a rung comment.

Note:
The Fun No. of MOV depends on PLC types.
CS-series -> 021
CJ-series -> 021
CV-series -> 030
C-series -> 21
Refer to the former pages to enter rungs and comments.

5-17. Entry of Timer Instructions

Entry of a Timer bit

Entry of a Timer instruction
Refer to the former pages to execute coding.

5-18. Entry of Counter Instructions

Entry of a Counter instruction

Move the cursor by using arrow keys or a mouse. Enter a bit for reset.

Entry of a Counter bit

Opening a new project

Device type settings

Creating a program
5-19. Edit of Rungs …Copy & Paste

Refer to the former sections to enter a rung.

You can also cut selected rungs (instructions) by [Ctrl]+[X].

Move the cursor to this position. The rung is inverted as shown right.

Ctrl + C
(Copy a rung)

Press the ↓ key to move the cursor to this position.

Ctrl + V
(Paste a copied rung)

Click each instruction and then change the bit numbers.

✦ When making a mistake, press or [Ctrl+Z] for Undo
  (return to the previous operation)
  press or [Ctrl+Y] for Redo (go to the next operation)

5-20. Entry of END Instruction

At the creation of a new project, a section of the END instruction only is automatically generated.
You do not need to enter an END instruction.

Note:
The END section is not generated when you load a program created with CX-Programmer V2 or the former versions.
Chapter 2
Online / Debug
1. Program Error Check (Compile)

Before program transfer, check errors.

- Output Window automatically opens at program check.
- The cursor moves to an error location by pressing J or F4 key.
- Output Window closes by pressing the ESC key.

Errors and addresses are displayed on Output Window.

Double-click a displayed error, and the cursor in Ladder Diagram will go to the corresponding error location and the error rung will be shown in red.

Modify the error.
2. Going Online

CX-Programmer provides three kinds of connecting methods depending on usage.

- Normal online. Enables you to go online with a PLC of the device type and method specified when opening a project.
- Auto online. Automatically recognizes the connected PLC and enables you to go online with a PLC with one button.
- Online with Simulator. Enables you to go online with CX-Simulator with one button (You need to install CX-Simulator.)

This time, online/debug functions when working online with CX-Simulator are explained in this guide.

The background color of Ladder Window changes to gray.

Scan time is displayed (except for Program Mode).

The operating mode of the active PLC is shown.

The CX-Simulator Console box is shown.

Click
3. Monitoring

The on/off statuses of contacts and coils are monitored.

Change the PLC (simulator) to Monitor Mode.

Click [Yes].

If your program has a large volume of data, the scroll speed of the screen may become slow when monitoring. In that case, click the below icon to cancel monitoring once, scroll the screen to the address you want to monitor, and then change to monitoring mode again.

Toggles on/off of PLC monitoring.

The rungs being monitored are shown in a specified color.

The present value of I/O memory is shown.
4. Monitoring - 2 Monitoring Many Locations in Program at Once

You can split Ladder Window and monitor more than one location in a program at once.

Move the mouse pointer to the arrow position shown in the right figure and drag the cursor down with the left mouse button pressed.

The screen is divided into two panes up and down, and you can display any address in two panes respectively by using the scroll bars.

5. Monitoring - 3 Monitoring in Hex

Click to switch the display format of the present value of IO memory between decimal and hexadecimal.
6. Monitoring - 4 Watch Window

I/O monitoring of the addresses specified in Watch Window is executed.

Display Watch Window.

- Press the ENT key continuously for auto increment of addresses.

Enter a bit number that you want to monitor.

400

Example: Entry of 4CH 00Bit

Enter "." (period) between CH and Bit.

Or enter "400" without a period in the "Name or address" box and then specify "BOOL" in the "Data Type/Format" box (Reverse the box and then press B key form the keyboard.)

You can also enter a given address in this status.

The addresses registered in Watch Window are still stored when CX-Programmer is opened next time.
7. Monitoring - 5 Present Value Change and Binary Monitoring in Watch Window

The present values of bits and words are changed in Watch Window.

In Watch Window, binary monitoring is possible for the data that can be treated by the word.

Double-click the mouse.

An entry dialog opens.

Enter a new value that you want to change to.

4-word data is displayed in the binary system.

As shown in the guidance at the bottom of the dialog, Force On/Off and Set On/Off are enabled also by key operation.

Click the right mouse button on a bit, and you will be able to select Force On/Off and Set On/Off from the popup menu.
8. Useful Functions of Watch Window

Watch Window has a function that classifies and displays data in sheets like MS-EXCEL and names each sheet given names. This function is useful for debug or startup if you gather and manage the bits and words you want to check as one block in one sheet.

To add a sheet, select [Watch sheet] -> [Insert].

Right-click on Watch Window. -> Select [View] from the popup menu. And then you will be able to choose showing/hiding of each item on Watch Window.

It is useful to manage data if you name sheets by the phase or assembly.

The names set by this operation are all saved when the project is saved (extension: .opt). Therefore, they are loaded as well as data such as ladder programs when the project is loaded next time.
Drag & Drop from Ladder Diagram enables you to add an address to be monitored.

Data such as rungs, bits per block, or operands of advanced instructions is pasted on Watch Window. Moreover, the on/off statuses of the bits and the present values of words are displayed.
10. Monitoring - 7 Rung-wrap of Long Rung on Display

This function makes a rung longer than the right bus bar as shown in the below figure wrap when displayed.

Select [View] -> [Show in RungWrap].

Once set, this function is always active until released by taking the reverse procedure of the above one.
11. Monitoring - 8 Differential Monitor

The function detects differential up/down of a specified bit and indicates that differential conditions are satisfied by sound or display. The function eliminates the use of a trap rung for checking operation and improves the efficiency of programming and debug operations.

Move the cursor to a bit to be monitored.

Or click the right mouse button on the applicable bit and select [Differential Monitor] from the popup menu.

Click [Start].

The count number is displayed on the dialog every time the differential condition (differential up in this example) is satisfied and the color of the box changes each time.
12. Force On/Off

Contacts/coils are forced on/off from CX-Programmer.

Move the cursor to a contact or coil that you want to force on/off.

Click the right mouse button. -> [Force] -> [On]

Mark indicates that the bit is now being forced on/off.

Force Off/Cancel of bits/coils are enabled in the same way.

Shortcut Key
Ctrl+J: Force On
Ctrl+K: Force Off

Once bits/coils are forced on/off, the forced statuses are held until cancelled or the reverse procedures of on/off are taken. The statuses do not change by an external input or the operational result of the program. Moreover, force operations are not enabled when the PLC is in the Run mode.

13. Displaying List of Forced-on/off Bits

The bits forced on/off can be listed in a table. This function enables you to check the forced statuses of more than one bit at a glance. This function is available when you connect to the actual PLC.

Display Project Workspace.
[Alt] + 1

Double-click [Memory].

Click the [Address] tab.

Double-click [Forced Status].
14. Changing Set Value of Timer

The set value of a timer is changed while CPU is running (in the Monitor mode only).

Move the cursor to the set value of a timer.

Enter the new set value #100.

Click [OK] to complete.

15. Changing Present Value of Timer

The present value of a timer is changed while CPU is running (in the Monitor mode only).

Move the cursor to the present value of a timer.

Enter a new present value 5000.

Click [Set] to complete.
16. Find Function - 1 Find from Address Reference Tool

Display Address Reference Tool.

Alt + 4

Reference

Enter a bit number that you want to find in the [Address] field.

Click the found bits are listed.

The found bits are listed.

You can also move the cursor to a bit that you want to find.

Click a bit that you want to find, and the focus will move to the corresponding position in the rung.

2-13
17. Find Function - 2 Retrace Find of Ladders

The function retraces ladder rungs so that you can find the causes of the coils not turned on.

(1) The reason why the coil 3.00 is not turned on is that its contact 2.00 is not turned on. Therefore, the function retraces rungs to find the coil 2.00.

(2) Move the cursor to the following position (contact 2.00) and press the [Space] key.

(3) The reason why the coil 2.00 is not turned on is that the contact 1.00 or 1.01 is not turned on. Suppose the cause is the contact 1.00 and find the coil of 1.00. Move the cursor to the contact 1.00 and press the [Space] key as well as the above operation (2).

(4) If this rung is not a cause press [Shift]+[Space], and you will able to go back to the rung before you started to find this rung.
(5) Then retrace rungs to find a cause from the contact 1.01. As well as the operations so far, move the cursor to the contact 1.01 and press the [Space] key.

(6) The focus moves to the coil 1.01. As it turned out, the cause was the contact 0.01 that was not turned on.

Press the [Space] key to jump from a coil to a contact having the same address as the coil or from a contact to a coil in reverse.

Press the [N] key for another jump from a contact or coil at the cursor position to a next one having the same address.

To move back to the position of the last jump, press the [B] key.

This is a useful function available in SYSMAC Support Software. CX-Programmer inherits it.
18. Find Function - 3 Find by Keyword in Comment

If you enter an operator’s name or an operation date in annotations as a note at startup or maintenance, this function finds the bit or word that the name or date is used and displays the result on Output Window.

1. Click 
   The [Find] dialog shows up.

2. Enter a keyword to find.
3. Select the [All (strings)].
4. Click [OK].

The contacts/coils of which annotations include the keyword entered in the Find dialog are displayed on Output Window.

Scope of Find is specifiable.

- **PLC**
  To find a target from all tasks (programs) and symbol table.

- **Program**
  To find a target from all tasks (programs).

- **Current view**
  To find from a section or symbol table being edited.

Double-click an item, and then the cursor moves to the applicable bit in Ladder Window.
19. Find Function - 4 Go To Rung Comment

This is a function that displays a list of rung comments on the screen and moves the cursor to the position where a selected rung comment is used in the ladder. Rung comments improve the efficiency of debug or maintenance of rungs divided into blocks per function.

A list of the rung comments used in rungs are displayed on a separate window.

Click a rung comment in the list, and the cursor goes to the position where the rung comment is used in the ladder.
20. Find Function - 5 Find Bit Addresses

Click the right mouse button on Ladder Window. Select [Find Bit Addresses] from the popup menu.

Enter an address (bit number) to find. (period between a channel and a bit is unnecessary.)

Set the scope of Find (Current view).

Click [Report].

Click [OK].

Output Window is displayed and the results are listed.

Double-click an item in the list, and the cursor will go to the applicable bit.

Find Addresses and Find Mnemonics are also available.
21. Online Edit

(1) Move the cursor to a rung you want to modify.


(3) Enter a bit number (4.11 in this example) you want to edit to.


You can also select more than one rung by Drag&Drop with a mouse.
Useful Functions

You can select either vertical or horizontal display of output instructions.

Vertical display of output instructions

Horizontal display of output instructions

[Tools(T)] -> [Options(O)]

Check the [Show output instructions horizontally] box.